PulseAudio 1.0 + JACK + Ubuntu 11.10 - 14 Октября 2011 - Боровск.ucoz.ru

Вы вошли как Гость | Группа "Гости" Гость |

Главная » 2011 » Октябрь » 14 » PulseAudio 1.0 + JACK + Ubuntu 11.10
17:21
PulseAudio 1.0 + JACK + Ubuntu 11.10
Приветствую читателей портала Боровск.юкоз ! Сегодня хотелось бы рассказать о трудностях и проблемах, которые возникли при настройке PulseAudio с JACK. Разработчики PulseAudio написали единицу в версии своей программы. Что нам это дает? Конечно же, улучшенную совместимость с JACK. Отныне не надо создавать файл .asoundrc и прописывать в нем код.

Так значит, так значит, так. Имеем дистрибутив Ubuntu 11.10 и Pulseaudio 1.0 ,соответственно, тоже. Ставим JACK. Доставляем мега-пакет pulseaudio-module-jack. И все вроде бы ничего, в JACK соединения созданы, PulseAudio JACK Sink и PulseAudio JACK Source присутствуют, но наблюдается парадокс. Звука нет. Ученые начинают думать, что же не так в теории, пересматривают постулаты. Но собака оказывается зарыта в ALSA plug-in [plugin-container]. И в настройках звука, конечно же. Отправляемся в Pavucontrol, в меню громкость выставляем у ALSA plug-in [plugin-container]  — Jack sink (PulseAudio JACK Sink) и радуемся звуку.


На сегодня всё. Но я уверен, это всего-лишь начало начал. Данный материал будет иногда обновляться, по мере возникновения новых трудностей.

Категория: Linux | Просмотров: 1325 | Добавил: fRee | Теги: Pulseaudio, Jack, ubuntu 11.10, PulseAudio 1.0 | Рейтинг: 0.0/0
Всего комментариев: 3
3  
Как ты вообще добился запуска jackd?
sudo aptitude install jackd2
Следующие НОВЫЕ пакеты будут установлены:
jackd{a} jackd2 jackd2-firewire{a} libjack-jackd2-0{ab} qjackctl{a}
0 пакетов обновлено, 5 установлено новых, 0 пакетов отмечено для удаления, и 9 пакетов не обновлено.
Необходимо получить 1 237 kБ архивов. После распаковки 4 153 kБ будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
libjack0: Конфликтует: libjack-0.116 который является виртуальным пакетом.
libjack-jackd2-0: Конфликтует: libjack-0.116 который является виртуальным пакетом.
Конфликтует: libjack0 но установлен 1:0.121.0+svn4469-2ubuntu2.
Следующие действия разрешат зависимости:

Удалить следующие пакеты:
1) libjack-dev
2) libjack0
3) tuxguitar-jack

2  
ставь jackd2 не раздумывая, ибо круче. а jackd1 удаляй)

1  
там проекты разошлись просто, одни захотели свой блэкджэк и шлюх, а другие - свой

Добавлять комментарии могут только зарегистрированные пользователи.
[ Регистрация | Вход ]